re = /(\d{2,4})(-|\/|:)(\d{1,2})(-|\/|:)(\d{1,2}) \d\d:\d\d(:\d\d){0,1}/
str = '15-15-01 12:01:23
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end