using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"utm_([a-z]*)?=(([a-z_-]||\d)*)?";
string input = @"https://test.com/grazhdanstvo-bolgarii.html?utm_source=google&utm_medium=search&utm_campaign=top&utm_content=text1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}