// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)utm_([a-z]*)?=(([a-z_-]||\d)*)?").unwrap();
let string = "https://test.com/grazhdanstvo-bolgarii.html?utm_source=google&utm_medium=search&utm_campaign=top&utm_content=text1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}