const regex = /utm_([a-z]*)?=(([a-z_-]||\d)*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('utm_([a-z]*)?=(([a-z_-]||\\d)*)?', 'gm')
const str = `https://test.com/grazhdanstvo-bolgarii.html?utm_source=google&utm_medium=search&utm_campaign=top&utm_content=text1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}