re = /utm_([a-z]*)?=(([a-z_-]||\d)*)?/m
str = 'https://test.com/grazhdanstvo-bolgarii.html?utm_source=google&utm_medium=search&utm_campaign=top&utm_content=text1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end