package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)utm_([a-z]*)?=(([a-z_-]||\d)*)?`)
var str = `https://test.com/grazhdanstvo-bolgarii.html?utm_source=google&utm_medium=search&utm_campaign=top&utm_content=text1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}