package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(JO|jo|Jo|jO)[0-9]{2}(?:[-| ]?[A-Za-z]{4})(?:[-| ]?[0-9]){22}$`)
var str = `jo12aVcd1234567890123456789012
Jo12VVCA1234567890123456789012
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}