re = /^(JO|jo|Jo|jO)[0-9]{2}(?:[-| ]?[A-Za-z]{4})(?:[-| ]?[0-9]){22}$/m
str = 'jo12aVcd1234567890123456789012
Jo12VVCA1234567890123456789012
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end