import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(JO|jo|Jo|jO)[0-9]{2}(?:[-| ]?[A-Za-z]{4})(?:[-| ]?[0-9]){22}$";
final String string = "jo12aVcd1234567890123456789012\n"
+ "Jo12VVCA1234567890123456789012\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}