using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""ICON=data:image[^""]+""";
string input = @"asdfasd fsda
asdfasd fasdfsad f""ICON=data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAACpElEQVQ4jY2Qy2tUZxjGf+/3nePcmDO""
sd fasdfdsafasdf
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}