re = /"ICON=data:image[^"]+"/m
str = 'asdfasd fsda
asdfasd fasdfsad f"ICON=data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAACpElEQVQ4jY2Qy2tUZxjGf+/3nePcmDO"
sd fasdfdsafasdf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end