const regex = /"ICON=data:image[^"]+"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"ICON=data:image[^"]+"', 'gm')
const str = `asdfasd fsda
asdfasd fasdfsad f"ICON=data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAACpElEQVQ4jY2Qy2tUZxjGf+/3nePcmDO"
sd fasdfdsafasdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}