package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"ICON=data:image[^"]+"`)
var str = `asdfasd fsda
asdfasd fasdfsad f"ICON=data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAACpElEQVQ4jY2Qy2tUZxjGf+/3nePcmDO"
sd fasdfdsafasdf
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}