$re = '/"ICON=data:image[^"]+"/m';
$str = 'asdfasd fsda
asdfasd fasdfsad f"ICON=data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAACpElEQVQ4jY2Qy2tUZxjGf+/3nePcmDO"
sd fasdfdsafasdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);