package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`file:\s?['"]?([^'"]+)`)
var str = `file: "word.124-ew/ef/?s=sf"
file: word.124-ew/ef/?s=sf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}