$re = '/file:\s?[\'"]?([^\'"]+)/';
$str = 'file: "word.124-ew/ef/?s=sf"
file: word.124-ew/ef/?s=sf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);