const regex = /file:\s?['"]?([^'"]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('file:\\s?[\'"]?([^\'"]+)', 'g')
const str = `file: "word.124-ew/ef/?s=sf"
file: word.124-ew/ef/?s=sf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}