// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"file:\s?['"]?([^'"]+)"#).unwrap();
let string = "file: \"word.124-ew/ef/?s=sf\"
file: word.124-ew/ef/?s=sf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}