re = /file:\s?['"]?([^'"]+)/
str = 'file: "word.124-ew/ef/?s=sf"
file: word.124-ew/ef/?s=sf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end