#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\[|!)(?<StiffenerName>(?:.*?))\s*(?=s\=|S\=)(?<StiffenerFactorSGroup>(?:s\=|S\=)(?<StiffenerFactorS>(?:\d)+(?:\.(?:\d)+)?))(?:\s*)(?<StiffenerMaterialGroup>(?:\*)(?<StiffenerMaterial>.*)(?:\*))?(?:\s*)(?:\]|!)"
Local $sString = "*Material A* 'Description' th.6 (85.8) %0% !HP60x5 s=400 *Material B*!" & @CRLF & _
"*Material C* W:200x18 F:100x27 ( 87.2)" & @CRLF & _
"*Material A* 'Description' th.6 (85.8) %0% [HP60x5 s=400 *Material B*]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")