$re = '/(?:\[|!)(?<StiffenerName>(?:.*?))\s*(?=s\=|S\=)(?<StiffenerFactorSGroup>(?:s\=|S\=)(?<StiffenerFactorS>(?:\d)+(?:\.(?:\d)+)?))(?:\s*)(?<StiffenerMaterialGroup>(?:\*)(?<StiffenerMaterial>.*)(?:\*))?(?:\s*)(?:\]|!)/m';
$str = '*Material A* \'Description\' th.6 (85.8) %0% !HP60x5 s=400 *Material B*!
*Material C* W:200x18 F:100x27 ( 87.2)
*Material A* \'Description\' th.6 (85.8) %0% [HP60x5 s=400 *Material B*]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);