import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\[|!)(?<StiffenerName>(?:.*?))\\s*(?=s\\=|S\\=)(?<StiffenerFactorSGroup>(?:s\\=|S\\=)(?<StiffenerFactorS>(?:\\d)+(?:\\.(?:\\d)+)?))(?:\\s*)(?<StiffenerMaterialGroup>(?:\\*)(?<StiffenerMaterial>.*)(?:\\*))?(?:\\s*)(?:\\]|!)";
final String string = "*Material A* 'Description' th.6 (85.8) %0% !HP60x5 s=400 *Material B*!\n"
+ "*Material C* W:200x18 F:100x27 ( 87.2)\n"
+ "*Material A* 'Description' th.6 (85.8) %0% [HP60x5 s=400 *Material B*]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}