import Foundation
let pattern = #"(?:\[|!)(?<StiffenerName>(?:.*?))\s*(?=s\=|S\=)(?<StiffenerFactorSGroup>(?:s\=|S\=)(?<StiffenerFactorS>(?:\d)+(?:\.(?:\d)+)?))(?:\s*)(?<StiffenerMaterialGroup>(?:\*)(?<StiffenerMaterial>.*)(?:\*))?(?:\s*)(?:\]|!)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
*Material A* 'Description' th.6 (85.8) %0% !HP60x5 s=400 *Material B*!
*Material C* W:200x18 F:100x27 ( 87.2)
*Material A* 'Description' th.6 (85.8) %0% [HP60x5 s=400 *Material B*]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)