using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[|!)(?<StiffenerName>(?:.*?))\s*(?=s\=|S\=)(?<StiffenerFactorSGroup>(?:s\=|S\=)(?<StiffenerFactorS>(?:\d)+(?:\.(?:\d)+)?))(?:\s*)(?<StiffenerMaterialGroup>(?:\*)(?<StiffenerMaterial>.*)(?:\*))?(?:\s*)(?:\]|!)";
string input = @"*Material A* 'Description' th.6 (85.8) %0% !HP60x5 s=400 *Material B*!
*Material C* W:200x18 F:100x27 ( 87.2)
*Material A* 'Description' th.6 (85.8) %0% [HP60x5 s=400 *Material B*]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}