#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)type="user" N="(?![a-z]{2}\d{5}")[^"]*" status="active""
Local $sString = "type="user" N="ag12345" status="active"" & @CRLF & _
"type="user" N="he98745" status="active"" & @CRLF & _
"type="user" N="user1" status="active"" & @CRLF & _
"type="user" N="84566" status="active"" & @CRLF & _
"type="user" N="iu78965" status="active""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")