const regex = /type="user" N="(?![a-z]{2}\d{5}")[^"]*" status="active"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('type="user" N="(?![a-z]{2}\\d{5}")[^"]*" status="active"', 'gm')
const str = `type="user" N="ag12345" status="active"
type="user" N="he98745" status="active"
type="user" N="user1" status="active"
type="user" N="84566" status="active"
type="user" N="iu78965" status="active"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}