$re = '/type="user" N="(?![a-z]{2}\d{5}")[^"]*" status="active"/m';
$str = 'type="user" N="ag12345" status="active"
type="user" N="he98745" status="active"
type="user" N="user1" status="active"
type="user" N="84566" status="active"
type="user" N="iu78965" status="active"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);