using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"type=""user"" N=""(?![a-z]{2}\d{5}"")[^""]*"" status=""active""";
string input = @"type=""user"" N=""ag12345"" status=""active""
type=""user"" N=""he98745"" status=""active""
type=""user"" N=""user1"" status=""active""
type=""user"" N=""84566"" status=""active""
type=""user"" N=""iu78965"" status=""active""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}