import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "type=\"user\" N=\"(?![a-z]{2}\\d{5}\")[^\"]*\" status=\"active\"";
final String string = "type=\"user\" N=\"ag12345\" status=\"active\"\n"
+ "type=\"user\" N=\"he98745\" status=\"active\"\n"
+ "type=\"user\" N=\"user1\" status=\"active\"\n"
+ "type=\"user\" N=\"84566\" status=\"active\"\n"
+ "type=\"user\" N=\"iu78965\" status=\"active\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}