# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(0414|0424|0412|0416|0426)[-][0-9]{7}$/^[04](1|2)(2|4|6)$/g;t' <<< "0426-1234567"