$re = '/^(0414|0424|0412|0416|0426)[-][0-9]{7}$/';
$str = '0426-1234567';
$subst = "^[04](1|2)(2|4|6)$";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;