package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(0414|0424|0412|0416|0426)[-][0-9]{7}$`)
var str = `0426-1234567`
var substitution = "^[04](1|2)(2|4|6)$"
fmt.Println(re.ReplaceAllString(str, substitution))
}