import re
regex = re.compile(r"^(0414|0424|0412|0416|0426)[-][0-9]{7}$")
test_str = "0426-1234567"
subst = "^[04](1|2)(2|4|6)$"
result = regex.sub(subst, test_str)
if result:
print(result)