using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bdylan\b.+\bdylan\b";
string input = @"Lorem ipsum dylan dolor sit amet, consectetur adipiscing elit. Pellentesque sollicitudin vulputate ornare. Nulla facilisi. Ut pellentesque odio scelerisque, tempor enim ac, lobortis leo. Suspendisse elementum odio sed urna cursus hendrerit. dylan Cras cursus maximus enim, vitae efficitur justo elementum vitae.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}