re = /\bdylan\b.+\bdylan\b/
str = 'Lorem ipsum dylan dolor sit amet, consectetur adipiscing elit. Pellentesque sollicitudin vulputate ornare. Nulla facilisi. Ut pellentesque odio scelerisque, tempor enim ac, lobortis leo. Suspendisse elementum odio sed urna cursus hendrerit. dylan Cras cursus maximus enim, vitae efficitur justo elementum vitae.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end