// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bdylan\b.+\bdylan\b").unwrap();
let string = "Lorem ipsum dylan dolor sit amet, consectetur adipiscing elit. Pellentesque sollicitudin vulputate ornare. Nulla facilisi. Ut pellentesque odio scelerisque, tempor enim ac, lobortis leo. Suspendisse elementum odio sed urna cursus hendrerit. dylan Cras cursus maximus enim, vitae efficitur justo elementum vitae.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}