use strict;
my $str = 'Lorem ipsum dylan dolor sit amet, consectetur adipiscing elit. Pellentesque sollicitudin vulputate ornare. Nulla facilisi. Ut pellentesque odio scelerisque, tempor enim ac, lobortis leo. Suspendisse elementum odio sed urna cursus hendrerit. dylan Cras cursus maximus enim, vitae efficitur justo elementum vitae.';
my $regex = qr/\bdylan\b.+\bdylan\b/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}