const regex = /\bdylan\b.+\bdylan\b/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bdylan\\b.+\\bdylan\\b', '')
const str = `Lorem ipsum dylan dolor sit amet, consectetur adipiscing elit. Pellentesque sollicitudin vulputate ornare. Nulla facilisi. Ut pellentesque odio scelerisque, tempor enim ac, lobortis leo. Suspendisse elementum odio sed urna cursus hendrerit. dylan Cras cursus maximus enim, vitae efficitur justo elementum vitae.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}