import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(i|em|b)(\\w*)\\/(i|em|b)\\b";
final String string = "{\"query\":\"incessant\",\"sourceLanguage\":\"en\",\"targetLanguage\":\"en\",\"primaries\":[{\"type\":\"headword\",\"terms\":[{\"type\":\"text\",\"text\":\"in·ces·sant\",\"language\":\"en\",\"labels\":[{\"text\":\"Adjective\",\"title\":\"Part-of-speech\"}]},{\"type\":\"phonetic\",\"text\":\"/inˈsesənt/\",\"language\":\"und\"},{\"type\":\"sound\",\"text\":\"http://www.gstatic.com/dictionary/static/sounds/de/0/incessant.mp3\",\"language\":\"und\"}],\"entries\":[{\"type\":\"meaning\",\"terms\":[{\"type\":\"text\",\"text\":\"(of something regarded as unpleasant) Continuing without pause or interruption\",\"language\":\"en\"}],\"entries\":[{\"type\":\"example\",\"terms\":[{\"type\":\"text\",\"text\":\"the emincessant/em beat of the music\",\"language\":\"en\"}]}]}]}]}";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}