// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b(i|em|b)(\w*)\/(i|em|b)\b").unwrap();
let string = "{\"query\":\"incessant\",\"sourceLanguage\":\"en\",\"targetLanguage\":\"en\",\"primaries\":[{\"type\":\"headword\",\"terms\":[{\"type\":\"text\",\"text\":\"in·ces·sant\",\"language\":\"en\",\"labels\":[{\"text\":\"Adjective\",\"title\":\"Part-of-speech\"}]},{\"type\":\"phonetic\",\"text\":\"/inˈsesənt/\",\"language\":\"und\"},{\"type\":\"sound\",\"text\":\"http://www.gstatic.com/dictionary/static/sounds/de/0/incessant.mp3\",\"language\":\"und\"}],\"entries\":[{\"type\":\"meaning\",\"terms\":[{\"type\":\"text\",\"text\":\"(of something regarded as unpleasant) Continuing without pause or interruption\",\"language\":\"en\"}],\"entries\":[{\"type\":\"example\",\"terms\":[{\"type\":\"text\",\"text\":\"the emincessant/em beat of the music\",\"language\":\"en\"}]}]}]}]}";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}