#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([3-9][0-9]|[1-9][0-9][0-9][0-9]*)"
Local $sString = "10" & @CRLF & _
"30" & @CRLF & _
"31" & @CRLF & _
"68" & @CRLF & _
"100" & @CRLF & _
"300" & @CRLF & _
"5432"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")