$re = '/([3-9][0-9]|[1-9][0-9][0-9][0-9]*)/m';
$str = '10
30
31
68
100
300
5432';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);