package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([3-9][0-9]|[1-9][0-9][0-9][0-9]*)`)
var str = `10
30
31
68
100
300
5432`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}