using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([3-9][0-9]|[1-9][0-9][0-9][0-9]*)";
string input = @"10
30
31
68
100
300
5432";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}