const regex = /([3-9][0-9]|[1-9][0-9][0-9][0-9]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([3-9][0-9]|[1-9][0-9][0-9][0-9]*)', 'gm')
const str = `10
30
31
68
100
300
5432`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}