package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[0-9]{2,4}\b`)
var str = `ABC-L-W7P-1423
ABC-L-W7E-87
CH-L-W7-756
CH-M-311-MM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}