import re
regex = re.compile(r"\b[0-9]{2,4}\b", flags=re.MULTILINE)
test_str = ("ABC-L-W7P-1423\n"
"ABC-L-W7E-87\n"
"CH-L-W7-756\n"
"CH-M-311-MM")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")