$re = '/\b[0-9]{2,4}\b/m';
$str = 'ABC-L-W7P-1423
ABC-L-W7E-87
CH-L-W7-756
CH-M-311-MM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);