const regex = /\b[0-9]{2,4}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[0-9]{2,4}\\b', 'gm')
const str = `ABC-L-W7P-1423
ABC-L-W7E-87
CH-L-W7-756
CH-M-311-MM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}