// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[0-9]{2,4}\b").unwrap();
let string = "ABC-L-W7P-1423
ABC-L-W7E-87
CH-L-W7-756
CH-M-311-MM";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}